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Welcome to the User’s Guide for FreeDV, the free version of Digital Origin IntroDV. 
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• Chapter 4, “Adding Titles to Clips” 
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Chapter 1

Introduction to FreeDV

Welcome to FreeDV, the free version of Digital Origin IntroDV. FreeDV is digital 
video (DV) editing software that lets first-time digital video users experience the 
thrill of turning their videos into first-class movies right on their personal 
computers. FreeDV gives you a simple way to get started with DV. 

This chapter gives you an overview of FreeDV’s capabilities, shows you how to 
start a new project, and introduces you to the tools you’ll use to edit video stories 
with FreeDV. You can add capabilities to FreeDV by upgrading to the compete 
version, as summarized below. (Select “Upgrade” from the FreeDV Help menu, or 
contact Digital Origin for further information.)

FreeDV IntroDV complete version

Build Stories up to 3 minutes long. Build Stories of any length.

Work with up to 12 video clips at once. Work with unlimited number of clips.

One extra audio track for music, 
narration, etc.

Two extra audio tracks: Use one for 
music, the other for narration or sound 
effects.

Titling: Two title styles. Titling: Eleven title styles, dozens of 
variations, including moving titles.

Special Effects: Four transition styles, 
dozens of variations.

Special Effects: Ten transition styles, 
hundreds of variations and effects.

Import video clips and sound files 
from disk.

Import video clips, sound files and still 
images from disk.

Export your video Story for the web or 
email in several convenient formats.

Record your story on DV tape, or 
optimize your video Story for web or 
email delivery in a wide variety of 
configurable formats.

Control your DV camcorder right from 
your computer.

Control your DV camcorder right from 
your computer, and search for the next 
scene on the tape automatically.
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FreeDV—desktop video editing

FreeDV's easy-to-use design is tailored for PC users unfamiliar with DV editing 
techniques and terminology. 

What you can do

With FreeDV, you can connect your DV camcorder to your PC with a single cable 
and easily transfer footage to the PC. You can then perform editing tasks such as 
rearranging clips using a storyboard, adding music or narration through the 
camcorder's microphone, creating transitions between clips, adding titles and 
credits, and previewing your story on the camcorder or a TV monitor. When 
finished, you can make a QuickTime movie to e-mail to friends, family, and 
colleagues or post on the web. 

Because FreeDV is designed for the DV format, the quality of the video is 
determined by the quality of the camcorder. When you capture video to the PC for 
editing, the quality is maintained. 

Starting a project
Once you’ve installed FreeDV, you’re ready to start IntroDV and get to work 
creating a video story.

To launch IntroDV and create a new project:

1 From the Start menu, choose Programs>Digital Origin>FreeDV>FreeDV.

If this is the first time you’re creating a new Story in FreeDV, it will display a Project 
Format dialog box. If you have already launched FreeDV before, choose 
File>New, then proceed to step 3.

2 Choose a project format to use: NTSC or PAL, then click OK. 

NOTE: NTSC is the most common standard composite video signal used in 
the United States. PAL is the most common standard composite video signal 
used in Europe. Choose the project format that’s most appropriate for your 
equipment and output. FreeDV will use this format automatically when you 
create future projects.

3 Specify a name and location for your project and click OK.

TIP! FreeDV will store video clips on the same disk drive as your project file. 
Since video captured to your hard drive requires considerable space (216MB per 
minute), choose a drive with adequate free space. 
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TIP! Click the New folder icon  to create a new folder for the project file 

and all of the other files associated with this video story. Keeping all the files in a 
separate folder makes it easier to store them when the project is complete. 

To open an existing project:

1 Launch FreeDV.

2 Choose File>Open.

3 Use the Look In list box to navigate to the folder in which the project file is 
stored.

4 Select the file you want to open.

5 Click Open.

FreeDV project windows
Three windows appear in IntroDV: the Library window, the Cutting Room 
window, and the Story window.

The Library window
When you capture or import your clips into IntroDV, they appear in the Library 
window. IntroDV displays the first frame of each video clip in the Library window 
as a visual reference to the content of the clip. For more information on capturing 
and importing, see Chapter 2.
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The Cutting Room window
The Cutting Room window contains two smaller windows, the Clip Player and the 
Story Player.

The Clip Player (on the left) is where you view your clips and set Start and End 
Cuts (begin and end points) for them. The Story Player (on the right) is where you 
view the sequence of clips you’ve edited into a story, along with any titles and 
transitions you’ve added. For information about editing clips to create a story, see 
Chapter 3.

You can play back your story or your clips in the Cutting room. Video can play 
back in the clip window, or it can be displayed on the LCD screen or monitor of a 
camera that is connected to the system via FireWire. 

The 
Story 
Player

The 
Clip 
Player
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To display the video on the LCD screen or monitor, check the Display to the 
Camera options in the Camera tab of the Options dialog. If the Playback to 
Camera option is enabled, FreeDV will not playback video in the Cutting Room 
and instead send video playback out to the Camera’s LCD. (note: the Playback to 
Camera option is only supported if using Digital Origin’s FireWire interface card). 
If you choose to edit without an attached DV camera, you should deselect the 
Playback to Camera option.

TIP! If you choose to edit without an attached DV camera and instead rely on 
the Cutting Room to view your Story, you may find that older computers are too 
slow to provide smooth playback of video clips. Use the Playback Options tab of 
the Options dialog to adjust the playback quality. These Playback options only 
take effect when not displaying video on the camera. 

The Story window
The Story window is a graphic representation of all the clips you included in your 
story, displayed along a timeline.

The Story window lets you quickly see the order in which you’ve placed the clips, 
where the transitions and titles (text) occur, and how the video portion of your 
story relates to the audio portion.
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Chapter 2

Getting your Images and Sound into FreeDV

Your video story is comprised of video clips and audio clips that you recorded with 
your camcorder or that were created with another application. You “capture” clips 
and images from your camcorder and “import” clips and images from another 
application. For example, you might capture several video clips from a recent 
vacation and import a sound file that you downloaded from the web. This chapter 
describes how to capture and import clips and sound into your story. Once you’ve 
included the clips you want to use, you are ready to begin editing your story, as 
described in Chapter 3.

Capturing video from your camera
Use the FreeDV capture function to save clips from your Digital Video camcorder 
as movie files (in QuickTime format) on your computer’s hard drive. Once video 
clips are stored on the hard drive, you can assemble them into your video story.

When you capture clips from your camera, you capture both video and audio. 
FreeDV does not create separate audio and video tracks from captured clips. To 
remove the audio, turn its volume down. See Chapter 6 for instructions. 

Before you capture, make sure that your camcorder is turned on and connected to 
your 1394 FireWire Interface port. See the Digital Origin Website for information 
on compatible 1394 FireWire interfaces.
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Using the Capture window
Use the Capture window to transfer clips from your DV camcorder to your 
computer and save them to the Library. 

To display the Capture window, click the Capture button on the toolbar.

NOTE: If you do not have a project open, you will be asked to name the project 
before the Capture window displays. For more information, see “Starting a project” 
on page 3. 

The rest of this section describes the components of the Capture window. 
“Capturing from tape” on page 11 and “Capturing from the Lens” on page 12 
describe how to use these components to capture clips. 

Capture Window Preview
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The Capture window displays a preview of the video playing on your camcorder.

VCR buttons

When you are playing video from your camcorder in the Capture window, you can 
use the VCR buttons, as described in the following table, to locate the clip you 
want to capture. 

To: Use this button: Or this keyboard 
shortcut:

Play or pause the tape. Play/Pause Space bar

Stop the tape when you are 
done or if you want to rewind 
or fast forward at the fastest 
speed.

Stop Down-arrow

Fast forward the tape Fast Forward Shift Right-arrow

Rewind the tape Rewind Shift Left-arrow

Advance the tape one frame at 
a time

Step Forward Right-arrow
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Capture button

The Capture button starts or stops a capture. You can use the Enter key as a 
shortcut for this button. For more information on capturing, see “Capturing from 
tape” on page 11 or “Capturing from the Lens” on page 12. 

Disk Information

The Available Disk Space indicator (disk shape) shows how much space is 
available on your hard disk to store captured clips. 

The Available Time indicator (stop watch) shows how many minutes and seconds 
of video can be stored on your disk.

The Disk Performance indicator (cheetah) shows you the speed at which FreeDV 
stored the last clip to disk. This information is important, because it lets you know 

Rewind the table one frame at 
a time

Step Reverse Left-arrow

Slowly (1/10th speed) play the 
tape forward

Slow Play Forward Control Right-arrow

Slowly play the tape in reverse Slow Play Reverse Control Left-arrow

To: Use this button: Or this keyboard 
shortcut:
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if the performance of your disk drive is changing as it fills. Minimum performance 
is 3.6MB per seconds. FreeDV can compensate for slower storage rates, but you 
should try to keep the storage rate at or above the 3.6MB per second level. If disk 
performance declines, try removing unneeded files from your hard disk or running 
a defragmentation program (Please see the Troubleshooting section of the  
Installation Guide or, if using an OHCI compliant FireWire interface, see the 3rd 
Party FireWire Interfaces document on the Digital Origin Website).

Tape Information

Each digital video frame has the following information associated with it:

• Time code, in the format hours:minutes:seconds;frames

• Time at which the frame was recorded

• Date on which the frame was recorded

You can show one of these information items (time code is the default) in the 
display at the bottom of the Capture window. 

To switch the display between time code, time, or date, select the item you want 
from the list box.

If you think you will need to recapture a clip another time, you can note the time 
code of the beginning and end points of the clip.

NOTE: Some digital video camcorders reset the time code to 00:00:00;00 if you 
leave blank, unrecorded space between video clips. In this case, you will have 
more than one frame with the same time code on your tape. FreeDV may display a 
message about “discontinous time code” after capturing video from tape with this 
condition. This message is provided for your information and should not affect the 
quality of the clips captured to disk.

Capturing from tape
To capture clips that you’ve recorded on tape:

1 Load the appropriate tape into your camcorder and set the camcorder to VTR 
mode. (For instructions, see your camcorder’s User Guide.)

2 Click the Capture button in the Toolbar or choose File>Capture to display the 
Capture window. 
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3 Use the VCR buttons to play the tape and locate the clip you want to capture.

4 To start the capture, click the Capture button or press Enter while the tape is 
playing.

The clip plays in the Capture window as it is captured. 

5 Click the Capture button again or press Enter to stop the capture.

6 In the dialog box that appears, type a name for the clip and click the Save 
button. 

The new clip appears in the Library window. 

Capturing from the Lens
To capture clips directly from the camcorder’s lens:

1 Set the camcorder to Camera mode. (For instructions, see your camcorder’s 
User Guide.)

NOTE: Some camcorders shut down (to protect tape heads) when in camera-
mode for an extended period of time. To prevent your camera from doing so, 
remove the tape. 

2 Set up the camera to film the action you want to capture.

3 Click the Capture button in the Toolbar or choose File>Capture to display the 
Capture window. 

4 To start the capture, click the Capture button or press Enter while the tape is 
playing.

5 Click the Capture button again or press Enter to stop the capture.

6 In the dialog box that appears, type a name for the clip and click the Save 
button. The new clip appears in the Library window. 

Importing Video and Sound
In addition to capturing from your camcorder, you can import movie files and 
audio files stored on your hard disk and include them in your video story.

FreeDV allows you to import the following file types:

• Movie files: QuickTime (.MOV) and AVI (.AVI)

• Audio files: Wave (.WAV), AIFF (.AIF), Sun (.AU), and MPEG (.MP3)

When you upgrade to the complete version of IntroDV, you can also enhance your 
stories by importing still image files, in the following formats:

• Still image files: JPEG (.JPG), TIFF (.TIF), Bitmap (BMP), Photoshop (.PSD), 
Compuserve (.GIF), Mac OS PICT (.PCT), and Portable Network Graphics 
(.PNG)
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NOTE: In general, FreeDV supports importing of most of the same file types that 
QuickTime supports. Visit the Digital Origin Web site (www.digitalorigin.com) for 
the latest information on supported file types.
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To import a movie or audio file:

1 Select File>Import to display the Import dialog box. 

2 Use the Look In list box to navigate to the folder in which the file is stored.

3 Select the file you want to import.

TIP! Shift-click or Control-click to select several files at the same time.

4 Click Show Preview to display or listen to a preview of the clip stored in the file. 

If you don’t see a preview, click Create to create one. Use the following 
controls to preview the file.

To: Use this button:

Play the preview Play

Stop the preview Stop

Fast forward the preview Fast Forward
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5 Click Import to import the selected file(s).

The file(s) you imported appears in the Library window.

6 When you are finished importing, click Done to close the dialog box.

Working with Clips in the Library Window
The movie and audio clips that you capture or import are the raw material for your 
video project. They all appear in the Library window. Chapter 3 describes how to 
assemble your video project from these clips. 

Rewind the preview Rewind

Move to a specific point 
within the preview

Position indicator 

(Click and hold mouse button to drag.)

Change the volume of the 
preview

Volume

To: Use this button:
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To organize clips in the Library window, you can:

• Click to select a clip.

• Drag a selected clip to a different location in the window.

• Right-click on a clip in the Library window to display a shortcut menu with the 
following functions:. 

You can set the number of columns displayed in the Library window in the Library 
Window tab of the Options dialog.

To: Select this item from the 
short-cut menu:

Delete the selected clip Delete

Rename the selected clip Rename

Copy the clip to video tape (for more 
information, see Chapter 7)

Print to Tape

View the clip’s properties Properties
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Chapter 3

Editing Your Clips

Once you’ve captured your video clips from your camera, or imported existing clip 
files into FreeDV, you’re ready to arrange them into your own custom-made video 
story. 

This chapter explains how to review and edit your clips. For information on adding 
titles (words) to your story, see Chapter 4. To add transitions (such as fades and 
wipes), see Chapter 5. And to add sound effects or music, refer to Chapter 6. 

Working with clips in the Cutting Room window
To craft your video story, you should first review each clip in the Cutting Room. 
Here you can adjust the length of each clip, arrange clips in the desired sequence, 
and preview your story as you work.

Reviewing a clip
To review a clip: 

1 In the Library window, click the clip you want to work with. 

The first frame of the clip appears automatically in the Clip Player of the 
Cutting Room window. (If you don’t see anything in the Library window, it 
means you still need to capture or import your clips. See Chapter 2 for 
information.)

2 Click the Play Clip Selection button at the bottom of the Cutting Room window, 
or press C on your keyboard. 

The clip will play through from beginning to end.

3 To stop the clip at any point, click the Play Clip Selection button or press C 
while the clip is playing. Note, anytime you click the Play Clip Selection button 
the clip stops playing and goes back to the beginning.

To adjust audio volume, see Chapter 6. 

NOTE: If Display to the Camera During Playback is selected in Camera Options, 
you may only see your clip on your camcorder's LCD or an attached TV monitor 
while scrubbing. If you are editing without an attached camcorder or TV monitor, 
you may choose to de-select the Display to the Camera option in the Camera tab 
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of the Options dialog. Turning off this option may improve playback quality in the 
Cutting Room Clip Player.

You may view any part of your clip by “scrubbing” through it: 

4 Drag the Clip Time marker (the vertical red bar at the bottom of the Cutting 
Room window) forward or backwards. 

Scrubbing lets you see the part of the clip you’re interested in, stopping or starting 
when and where you like.

Editing a clip
Once you’ve familiarized yourself with a clip, you’re ready to select a portion of it 
for inclusion in your video story. You do this by setting the Start and End Cuts 
(where you want the clip to begin and end) using the scissors. 

NOTE: At times, you may want to include an entire clip in your story, without 
shortening it. In this case, you can simply add the entire clip directly to the 
story, as described in the next section.

TIP! In general, you should try to keep your clips on the short side (about three 
to five seconds long), to keep your viewers’ interest. But don’t shorten them too 
much; you want to give your viewers enough time to get the flavor of each video 
segment. The small Clip Duration window (bottom left of the Cutting Room win-
dow) shows you the current length of the clip.

To set Start Cut and End Cut:
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1 Drag the Start Cut marker (the scissors on the left of the Clip Time marker) to 
the precise point where you want your edited clip to begin. You can drag it 
backwards and forward until you’ve hit on the exact spot you want.

2 Drag the End Cut marker (scissors on the right of the Clip Time marker) to the 
point where you want the edited clip to end.

Notice that the Clip Duration time has decreased to indicate the length of 
selection.

You can now put the clip directly to your story by clicking the Add Clip button or 
continue editing as many clips as you like.

Putting your clips into the Story
Once you’ve adjusted the clip’s Start Cut and End Cut, you can add the clip into 
the Story —that is, you’re ready to place it in the sequence of all the clips that will 
make up your finished story.

Use one of the following methods to add a clip into the Story:

• With your edited clip in the Clip Player of the Cutting Room window, click the 
Add Clip button (the arrow between the Clip and Story Players). The clip 
appears as a green section in the Story window.

• Drag an edited clip from the Clip Player into the Story Player or Story Window.

• Drag an unedited clip directly from the Library Window into the Story Player 
window or Story Window.

If you intend to use the video from a clip with video, it must be added to the Video 
Track (the track with the movie camera icon at its leftmost end). If you wish to use 
just the audio portion of a clip, or a clip with no video, it must be dragged into the 
Music and Narration Tracks (the tracks with the musical note icon at their leftmost 
ends).

Reviewing your story in the Story Player
Add as many clips as you like to the Story. At any point, you can review the story 
using either the Story Player of the Cutting Room window, or the Story window. 

The Story Player works much the same as the Clip Player; the only difference is 
that your entire video story is accessible, instead of just a single clip. The current 
Story time is shown in the Story window at the bottom right of the Story Player.

NOTE: The Story window has a zoom-in and zoom-out button in the lower left 
corner to allow you to see a greater or fewer number of clips in the Story Window.

 There are two ways to review the story:

• Click the Play Story button in the Story Player to play or stop the story. Or 
press the spacebar to stop and start the story.
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• Drag the Story Time marker in the Story Player to scrub through the entire 
story, just as you can scrub through clips in the Clip Player.

At this point, the clips in your story are “spliced” together. If you find that the 
transition between one clip and another is rather abrupt, you can add transition 
effects such as fades and wipes. For more information, see Chapter 5.

Using the Story window to refine your story 
The Story window provides a streamlined representation of your story. It shows 
you:

• the order your clips will play in the story

• the length of each clip

• the length of any secondary audio tracks, and how they’re organized (see 
Chapter 6 for information about working with sound and music) 

You can quickly view, reorganize, insert, or delete clips from your story by using 
your mouse in conjunction with the Story window, as described in the following 
sections.

Scrubbing in the Story window
You can scrub through your story by dragging the red Story Time marker, just as 
you do in the Cutting Room window. As you scrub in the Story window, the Story 
Time marker in the Story Player moves, and you see your story in the Story 
Player.

NOTE: If Display to the Camera During Playback is selected in Camera Options, 
you may only see your story on your camcorder's LCD or an attached TV monitor, 
while scrubbing. If you are editing without an attached camcorder or TV monitor, 
you may choose to de-select the Display to the Camera option in the Camera tab 
of the Options dialog. Turning off this option may improve playback quality in the 
Cutting Room Story Player.

Adjusting audio volume
You adjust the volume of the original audio portion of all your clips by clicking the 
first speaker icon (near the top of the Story window, next to the camera icon). (You 
can also adjust the volume of individual clips or other sound effects you add; more 
on that in Chapter 6.)

Editing clips
In the Story window, you can adjust the length of any clip in your story by changing 
the Start Cut and End Cut.

1 Select the clip you want to edit by clicking it. A yellow border appears around 
the selected clip.
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2 Drag the left end of the clip to reset the Start Cut; drag the right end to reset 
the End Cut. 

Adjacent clips in your story automatically fill in the Story to occupy any gaps 
you may have created by changing the Start Cut and End Cut.

As you edit in the Story window, the Clip Player (in the Cutting Room window) 
shows the changes you make to the selected clip.

Rearranging clips
In reviewing your story, you may decide that the clips should be arranged in a 
different order. To reorganize your clips:

1 Select the clip you want to move by clicking it. A yellow border appears around 
the selected clip.

2 Use one of the following methods to move the clip:

• Click and drag the clip to the spot in the Story where you want it to appear.

• Choose Edit>Cut. Then move the red Story Time marker to the spot in the 
Story where you want the clip to appear, and choose Paste.

Once you’ve reordered your clips, you can play or scrub through the story, and if 
you like, continue experimenting with the order of the clips until the arrangement 
suits you. 

TIP! You can also use shift-select to select several clips at a time in the Story 
window. Use Cut and Paste from the Edit menu or simply drag to a new location.

Deleting clips
You can quickly remove a clip you’ve included in your story by doing the following:

1 Select the clip you want to delete by clicking it. A yellow border appears 
around the selected clip.

2 Use one of the following methods to delete the clip:

• Press the Del key on your keyboard

• Right click the clip and choose Delete.

• Choose Edit>Delete.

If you change your mind about a clip you’ve just deleted, choose Edit>Undo.

Inserting clips
There may be times when you want to insert another video clip in the middle of 
one you’ve already added to your story. 

To create a gap in the middle of a clip to insert a second clip: 

1 In the Story window, move the red Story Time marker to the exact point you 
want to insert the new clip. 

2 Select the track containing the clip you want to split.
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3 Choose Edit>Split Clip. 

4 The selected clip will be split into two segments. 

5 Drag and drop a new clip from the Clip Player into the split you created, or add 
a clip to the story at the split point by placing the red Story Time marker at the 
cut and clicking the Add clip to Story button in the Cutting Room. 

6 If you like, scrub through or play the Story to see how well your inserted clip 
fits into the movie.

Viewing clip properties
As with most Windows-based programs, FreeDV includes a Properties command. 
Just right-click any clip to view a tabbed dialog box that gives helpful information 
about that clip:

• General tab: The clip’s name, size in kilobytes, creation date, original duration, 
horizontal x vertical dimension, and time scale. There is also a Comment text 
box where you can enter notes about the clip.

• Track info tab: The clip’s file type, format, depth, and frame or sample rate is 
displayed.

• Files referenced tab: Files referenced by the clip.
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Chapter 4

Adding Titles to Clips

Adding titles or credits to your images enriches the viewing experience for your 
audience by providing them with information or augmenting the mood. Adding text 
to images also orients your viewers to what they’re seeing in the video image, and 
gives them a clearer sense of the overall message you’re conveying. And, of 
course, you can give yourself and your cast credit for the production.

Using titles

FreeDV provides a variety of preset titles that you can easily add to your images. 
Each preset title has settings which you can change to enhance the text on your 
image. Many additional title styles, including custom titles, become available when 
you upgrade to the complete version of IntroDV.

Adding titles
Adding a title is a drag and drop procedure that launches a dialog box in which 
you can add the text you want and specify its settings. You can choose to keep the 
default settings or change them before you add the title to your image. 

To add a title:

1 Click the Titles button on the toolbar or choose View>Effects.

The Effects window opens showing its two panes. The left pane contains a 
Transitions folder and a Titles folder. As you click each folder, its contents 
appear in the right pane. 

2 Make sure that Titles is highlighted on the left side of the window.

A list of titles appears in the right pane.
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3 Drag the title you want into the Story window and place the cursor on the T 
track right below the clip in which you want the title to appear. When you see a 
rectangle and the insertion cursor (a vertical black bar), release the mouse 
button to apply the title.

A dialog box appears with the name of the title at the top. The dialog box 
contains a text field and the settings that customize the text.

4 Enter the text you want for your title in the text area.

5 Keep the default settings, or choose a different font and color.

You can edit or customize your title settings at any time—while you’re adding 
the title or after you’ve added the title in the Story window. See “Editing a title” 
on page 25 for details.

6 Click OK.

Insertion Cursor
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The story automatically builds and includes the title on the image. When the story 
finishes building, you’ll see the title name below the clip in the Story window.

At this point, you can add more titles, preview the clip with its title, or edit the title 
to further customize it. If you want to delete a title, see “Deleting a title” on 
page 26.

NOTE: This is a good time to save your project if you haven’t done so already. 
Even if you’re going to continue to make changes, it’s a good idea to save your 
project periodically.

Previewing a title
When you’re ready to preview the title on the image, you can do so by scrubbing 
through the clips in the Story window.

To preview the title:

1 In the Story window, grab the red Story Time marker with your cursor and 
place it at the beginning of the section of your Story you wish to view. 

2 Click the Play button in the Story Player or press the space bar to watch your 
Story play. 

3 As you preview your Story and view the titles, you might find that some of the 
text could be a different font size or color. You can change these settings by 
editing the title settings.

Editing a title
Editing your titles is a matter of changing their settings after you’ve previewed your 
clips with the titles on the images. The editing process is a simple one—you can 
edit the titles directly from the Story window. 

NOTE: Titles are always the same length as the clip they are attached to. You 
cannot shorten the duration of a title without shortening the clip it is attached to, or 
splitting a clip into smaller segments. See “Adding titles to a portion of a clip” for 
details.

To edit a preset title:

1 In the Story window, click the title to highlight it.

A yellow border appears around the title.

2 Double-click the title in the T track, right-click the title and choose Title 
Settings...or choose Edit>Title Settings.

A dialog box appears with the title name at the top. The dialog box contains 
the current settings for text font and color.

3 From the Font drop-down list, choose the font you want.

4 Click the Color box to launch the color palette and choose the color you want.
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5 Click OK.

The story automatically builds and includes the new title. You can view the new 
title by scrubbing through the clip in the Story window or by playing the Story.

Deleting a title
After you preview your clips, you might see some titles that aren’t quite right. 
Perhaps the wording doesn’t convey the right message, or perhaps it looks a bit 
crowded on the image. You might decide to remove the title altogether and rethink 
your message. Removing a title is very easy. 

To delete a title:

1 In the Story window, click the title to highlight it.

A yellow border appears around the title.

2 With the title highlighted, press the Delete key or choose Edit>Delete. You can 
also right-click the title and choose Delete from the menu.

The story automatically builds and removes the title.

More on titles
When you first drag and drop a title onto the T track in the Story window, the title 
length automatically adjusts to match the length of the clip. If you change the 
length of a clip later, the associated title will automatically adjust to the new length. 
Both preset and custom titles are always the same length as the clip they are 
attached to.

Adding titles to a portion of a clip
If you wish for your title to appear during part of a clip, instead of during the whole 
clip, you can split the clip into smaller segments in the Story, and apply the title 
effect to one of the shorter segments.

To title a portion of a clip: 

1 In the Story window, move the red Story Time marker to the exact point in the 
clip at which you want the title to begin or end. 

2 Select the track containing the clip.

3 Choose Edit>Split Clip. 

4 The selected clip will be split into two segments.

5 Apply the title effect to the portion of the clip that you want to title. 

6 Choose your title settings normally.
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Chapter 5

Adding Transitions Between Clips

Transitions provide visual segues between clips and can be used to influence the 
mood and pace of your program. Without transitions, your clips move from one to 
the other using cuts, which are instantaneous switches from one clip to another. 
While this type of edit should be used most often within your story, some aspects 
of your movie may be enhanced by using a transition between scenes. 

FreeDV provides a variety of transition effects. You can choose transitions that 
gently fade your images into and out of the surrounding clips, or you can opt for 
exciting transitions that explode from one frame to another.

Using transitions
Transitions create an overlap between the clips using the images from beyond 
their cut points. This way, adding a transition does not affect the overall program 
length, which is useful when you have edited a “rough cut” of a project and wish to 
add transitions without altering synchronization between your video clips and your 
music and narration tracks.

However, you must have frames of video beyond the Start and End Cuts of your 
clips for FreeDV to create the necessary overlap. If you have added clips to the 
Story without adjusting their Start or End Cuts away from the very beginning and 
ending of the clip, you will need to adjust the length of the clip as described in 
“Editing clips” on page 20.

Furthermore, many transitions will not appear to have an effect if applied to an edit 
created using the Split Clip command. This is because FreeDV will blend identical 
frames together, which produces no change. You may therefore need to adjust the 
length of the clip as described in “Editing clips” on page 20.

Each transition has default settings, such as starting and ending locations, 
blurring percentages, shapes, angles, and borders, which you can edit or 
customize to enhance the look and feel of your video story. 
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FreeDV uses standard Apple QuickTime® transitions. A brief description of each 
transition is listed in the following table. Many more transitions and special effects 
become available when you upgrade to the complete version of IntroDV.

Adding a transition
Adding a transition is a drag and drop procedure that opens a dialog box in which 
you can view the transition’s behavior. You can choose to keep the transition’s 
default parameter settings or change them before you add the transition to your 
clips.

To add a transition:

1 Click the Transitions button on the toolbar, or choose View>Effects.

Transition Description

Cross fade Performs a smooth fade from one clip to another. You can 
specify the starting and ending percentages of the fade, 
which indicate the opacity or saturation of the blended 
image. For example, if you choose 0% (the highest 
saturation), the new image completely covers the old 
image as the fade occurs. If you choose 100% (the 
lowest saturation), the new image and old image have 
equal saturation and both remain visible throughout the 
fade.

Explode Rapidly expands the new clip from small-to-large so that 
it covers the old clip. You can specify the starting and 
ending explode center locations, which can be outside 
the image’s visual area.

Gradient wipe Uses a black and white still image (called a “gradient 
map”) to determine which portions of each clip is visible 
over the course of the transition, substituting pixels from 
the new clip for those in the old in the order of brightness. 
Depending on the gradient map you use, this can have 
spectacular results. (Elaborate gradient maps are 
available from third parties such as Pixelan SpiceRack.) 
You can specify how much of the old image you want to 
cover by using the percentage sliders, and you can blur 
the leading edge of the wipe.

Wipe Covers the old image completely with the new with a 
wiping motion. There are 36 wipe patterns, which you 
can customize by tiling vertically and horizontally. You 
can specify a border width and color, and you can soften 
the border edge.
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The Effects window opens showing a list of available transitions.

2 Drag the transition you want into the Story window and place the cursor 
between the two clips where you want the transition to occur. When you see 
the insertion cursor (a vertical black bar), release the mouse button to apply 
the transition.

A dialog box appears with the name of the transition at the top. The dialog box 
contains the settings that change the transition’s look and behavior, and a 
small preview window. 

3 Keep the default settings, or change any settings you want to customize the 
transition. The results are shown in the preview window. 

You can edit or customize your transition settings at any time—while you’re 
adding the transition or after you’ve added and previewed the transition in the 
Story window. See “Editing a transition” on page 30 for details.

4 Click OK.

The story automatically builds and includes the transition. When the story 
finishes building, you’ll see the transition name between the clips in the Story 
window.

At this point, you can add more transitions, preview the clips with their 
transitions, or edit the transitions to further customize them.
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NOTE: This is a good time to save your project if you haven’t done so already. 
Even if you’re going to continue to make changes, it’s a good idea to save your 
project periodically.

Previewing a transition
When you’re ready to preview the transition, you can do so by scrubbing through 
the clips and transitions in the Story window or playing the Story.

To preview the transition:

1 In the Story window, grab the Story Time marker (the red vertical bar) with 
your cursor and move it to the beginning of the clip you want to preview.

2 Click play to preview the Story and your transition, or slowly drag the Story 
window marker to the right. You’ll see the clips and the transitions playing in 
the Story Player.

As you preview your clips and transitions, you might find that some transitions 
could use a few alterations. Perhaps they fill too much of the image area, or need 
a border for a sharper look. Or perhaps you want to change the transition shape 
from a square to an oval. You can change any of these effect settings by editing 
the transition settings.

Editing a transition
Editing your transitions is a matter of changing their settings after you’ve 
previewed your clips and transitions. You can customize your transitions at any 
time. 

Each transition has its own set of parameters. If you’ve experimented with the 
settings, you probably have a good idea of the types of things you can do with 
them. If you haven’t examined them yet, here’s a brief list of the types of things 
they can do:

• Change the size of the new image and specify whether or not it will completely 
cover the old image during the transition

• Add borders, soft edges, and background colors

• Change the shapes of the transitions (for example, from a square to an oval, or 
from a triangle to a matrix pattern)

• Change the center location for the starting and ending points

• Specify the direction in which a matrix pattern travels to cover the old image

• Specify a gradient and edge blur 

You edit transitions directly from the Story window.
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To edit a transition:

1 In the Story window, click the transition to highlight it.

 A yellow border appears around the transition. 

2 Right-click the transition and choose Transition Settings from the menu or 
choose Edit>Transition Settings.

A dialog box appears with the transition name at the top. The dialog box 
contains the settings that change the transition’s look and behavior, and a 
small preview window.

3 Change or set the parameters by using the sliders for percentages, by 
choosing items from a drop-down list, by selecting checkboxes, or by choosing 
X and Y axis parameters.

As you change each setting, the preview window shows the results. 

4 Click OK.

The story automatically builds and includes the new transition. You can view the 
new transition by scrubbing through the clip in the Story window or playing the 
story.

Go ahead and experiment with the different transition types and their parameters 
and see what kinds of effects you can create. After previewing your clips and 
transitions, you may find that one or two aren’t quite what you wanted. Removing 
a transition is very easy.

5

Deleting a transition
After previewing and editing your clips, you might decide to remove a transition 
altogether. Perhaps it doesn’t quite fit into your program, or perhaps you want to 
add another type of transition in its place.

To delete a transition:

1 In the Story window, click the transition to highlight it. 

A yellow border appears around the transition. 

2 With the transition highlighted, press the Delete key or choose Edit>Delete. 
You can also right-click the transition and choose Delete from the menu.

The story automatically builds and removes the transition.

More on transitions
In addition to editing your transition settings, you can change the length of the 
transition itself. By default, each transition is 30 frames (25 frames for PAL), 
approximately one second long. You can shorten or lengthen a transition by 
dragging its edges in the Story window. 
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Because a transition blends the clips from beyond the cut points, lengthening your 
transition obscures a bit more of your clips and shortening your transition leaves 
longer portions of your clips showing.

As with most visual programs, experimenting with the settings and viewing the 
behavior is the best way to achieve the aesthetic results you want. 
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Chapter 6

Working with Sound and Music

Music, narration and sound can dramatically improve the impact of your story. In 
addition to (or instead of) any original audio, you can add music, narration, and 
sound effects to your video stories. You can record sounds into your camera's 
microphone or into a microphone attached to your computer, or you can import 
other sound files directly into FreeDV’s library for use in your Story.

Importing sound files
In addition to audio captured with video by your camcorder, you can also import 
files in the following formats:

• .WAV

• .AIF

• .AU

• .MP3

• .SD2

• .MOV

NOTE: FreeDV supports most of the same audio file formats that QuickTime 
supports. Visit the Digital Origin Web site (www.digitalorigin.com) for the latest 
information on compatible file formats.

You import sound files the same way you do video: Choose File>Import, then 
choose the sound file you want.

Since your clips contain both video and audio, you automatically import audio at 
the same time you import the video. You can keep this sound with your final story, 
or you can replace it with different sound effects when you create your video story, 
as described later in this chapter.
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Quick start: Working with audio clips
You work with audio clips in much the same way as you do video clips. We 
recommend that you read Chapter 3 before this chapter. If you have done so, you 
already know the fundamentals of working with audio clips. Here’s all you do:

1 Import an audio file. 

An audio icon and the name of the file appear in the Library window.

2 Select an audio file by clicking it; the audio file’s icon and file name appear in 
the Clip Player.

3 Use the Play Clip Selection button (or press C on your keyboard) to play and 
stop the clip.

4 If you want to shorten the audio clip, set new Start Cut and End Cuts by 
dragging the scissors to the left and right.

5 Click the Add Clip button (between the Clip Player and Story Player) to add the 
audio clip to your video story. You may also drag the audio clip directly to the 
Music and Narration track.

You’ll see the clip’s File name in one of the sound tracks in the Story window. 
Sound tracks are shown with a musical note icon at the left.

6 Use the Play Story button in the Story Player to play the story, which now 
contains the music you've added.

NOTE: If you have a slower computer, the sound or picture may stutter during 
playback. If so, you can experiment with temporarily reducing the playback quality 
of the video so that your computer can improve sound quality. Choose 
View>Options, then click the Playback tab. You can then choose “draft” quality for 
playback.

7 Select audio clips you want to change (by clicking them) in the Story window. 

You can then rearrange them, set new Start Cut and End Cuts, or delete the 
clips.

8 Right-click an audio clip and choose Properties to view information about it.

9 Set the volume level for a clip by clicking the speaker icon inside the clip and 
dragging the knob up and down while the story is playing or paused.

Adjusting the playback volume for audio clips
You can individually change the volume level for each audio track in your story and 
for each separate video clip. For instance, you might want to completely suppress 
the sound of the original audio (if any), and replace it with voiceover narration and 
music. Or you might want to keep the original audio and have some music playing 
softly in the background.
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To change the volume of a track:

• Click the speaker icon next to the audio track in the Story window, then drag 
the slider on the volume control up or down. 

To completely suppress the sound of a track, drag the slider all the way to the 
bottom. For instance, to suppress the sound of any audio originally recorded with 
a video clip, click the speaker icon in the video clip in the Story window, then drag 
the slider all the way to the bottom. That way, any other sound you’ve added to 
your story, such as music or voiceover narration, can be heard. You can then fine-
tune the volume of your added sound tracks.

Creating voiceover narration
There are two ways to create voiceover narration for your video story: you can 
either record an audio voice track into the microphone on your camera or record it 
into a microphone attached to your computer’s sound card. 

Recording narration into your camcorder
You can create a voice track for your video story by simply shooting some more 
video footage that includes the narration you want. The video portion won’t matter. 
In fact, you can just turn the camera on and start speaking, without being 
concerned about what you’re recording visually. Unless, however, you also plan to 
use the video portion of the narration in your Story. 

When you’re finished speaking, you capture the narration you’ve recorded by 
clicking the Capture button or choosing File>Capture just as you do when 
capturing a video clip. 

Once the clip is in the Library window, you can edit and preview the audio section 
as described earlier in the chapter. Then, with Start and End Cuts set, drag the 
video clip past the video track and directly onto the audio track in the story line at 
the point in the story you want it to play. Only the audio portion of the clip will 
appear in the final story. 
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Recording narration into your computer
If you prefer, you can bypass your camera and speak directly into a microphone 
connected to your computer’s sound card. Windows comes with a built-in sound 
recorder. 

• Windows 95: From the Programs menu, choose 
Accessories>Multimedia>Sound Recorder. 

• Windows98: From the Programs menu, choose 
Accessories>Entertainment>Sound Recorder.

You can then save the narration in .WAV format.

Alternatively, you can use one of the many sound recording packages available for 
Windows95 or Windows98 to record and save audio. 

Adding music to your story
You can add music to your video story by plugging a CD player or other audio 
output device into your computer’s sound card, or by importing an existing audio 
file containing music into FreeDV.

As with recording voiceover narration, you can use the Sound Recorder supplied 
with Windows, or any of a number of sound recording packages available for 
Windows95 or Windows98. 
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Chapter 7

Printing to Videotape

When you complete your video story, you can:

• Use your camcorder to "preview" (play) it on the LCD

• Use your camcorder to "print" (record) it onto videotape (only in the complete 
version of IntroDV)

• Export it as a QuickTime movie which can be used in other QuickTime 
compatible applications

Printing your story to videotape (complete version of IntroDV only)
When you print your story to videotape, IntroDV records the story onto the tape in 
your camcorder. You can then view the tape on any digital video player (such as 
the camcorder or a VCR).

To print your story to videotape:

1 Load a new, blank tape or an old tape you are willing to record over into your 
camcorder.

2 Click the Print button on the toolbar or choose File>Print to Tape.

The Print to Tape dialog box appears.
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3 If you want to see a blank screen before and after your story, select Blank 
Screen 3 Seconds before and after.

4 To preview the story on the camcorder’s LCD or an attached TV monitor, click 
Play. 

TIP! Depending on the capabilities of your PC, the story may look better when 
you play it on a video device (such as the camcorder or a video monitor). Preview-
ing the story before you record it to tape lets you see it exactly as it will appear on 
video. 

5 To record the story to videotape, click Record.

A progress message lets you know when the recording is complete.

Exporting your movie to QuickTime
When you export your story as a QuickTime movie, it can be opened in any 
application that is QuickTime compatible such as Terran Media Cleaner Pro or 
Adobe After Effects. If you are interested in creating a QuickTime-based Web 
movie, see Chapter 8.
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To export your story to a QuickTime movie:

1 Choose File>Export Story.

The Export Story dialog box appears.

2 Select the folder where you want to store the movie file, and enter a file name.

3 Click the radio button to save movie as a self contained QuickTime movie.

4 Click Save. The exported story file can now be opened by QuickTime Pro or 
imported into other QuickTime compatible applications. 

When you’ve finished your story
When creating a story you use many computer files to store the video clips you 
capture from your camera and the special effects and titles that you add to your 
story. These video clips are stored on your hard disk in the same folder as your 
project file in a folder named project name media. Thus, a project named 
MyStory.zdv would store all of its video clips in a folder named MyStory media. As 
long as you wish to continue editing your story, your clips must remain in this 
media folder.

At some point, you will finish editing your story and save the edited movie back to 
video tape. You can recover the disk space used by the video clips by removing 
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the project file and its associated media folder from your disk drive. These files 
can be removed by using the Windows Explorer to delete the folder. However, 
once this media folder is removed, you will no longer be able to play or edit your 
story from your computer. Therefore, do not remove this folder and project until 
you are completely finished editing your movie.

NOTE: Once you have removed this media folder, any story files that you have 
exported with the Export Story (as a temporary Reference Movie) command will 
no longer be able to play. These small exported files refer back to your original 
video clips and can only play provided the original clips are available.
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Chapter 8

Creating Web Movies 

Making a good compressed movies starts by capturing and editing your source 
material at the highest quality possible. FreeDV is an ideal environment for editing 
web movies because it preserves full frame-rate and full resolution DV files 
(720x480 for NTSC; 768 x 576 for PAL). While FreeDV maintains the quality of 
your original footage, the movie files it creates are very large. Therefore, it is 
important that, once you have completed editing your Story, you reduce its size by 
exporting it to a compressed format. This section describes the main steps 
required to save a completed Story to a format appropriate for low bandwidth 
delivery. 

Export your Story for the web
Creating a compressed movie with FreeDV is performed once your Story is 
complete. It is highly recommended that you begin by experimenting with a short 
5-10 second test clip from your Story. Using a short test movie allows you to 
quickly compress and compare results using different settings. 

Save your movie from FreeDV

1 With your completed project open, select the Export button or go to File-> 
Export.

2 Choose a destination for your exported movie. Your Story title and directory is 
the default name and destination for the exported file. The default format is 
“Movie to QuickTime Movie”.
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Tips for improving video quality

Experimentation is the key to finding the right balance between playback quality 
and file size. 

• Save time by experimenting first with a short 5-10 second clip before trying to 
compress longer movies.

•

• Be sure to use bright daylight footage. Dark images compress poorly.

• Avoid footage with high motion sequences which are more difficult to 
compress.

3
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